The card that came with my carvewright failed to read at about 98% on the first project I attempted. After that, it made it though 4 or 5 projects before becoming totally unreadable by either the machine or my computer.

I ordered 2 new memory cards, they came, but it's been very hit & miss as to whether they work or not. One pattern in particular I cannot upload no matter how many times I try or what I do. It's the Eagle Clock from the CV pattern depot. Other patterns are hit & miss as to whether they will complete loading or not. Sometimes, I get lucky.

I've been reading, I moved the card reader to a USB on the back of my computer, I got rid of my cordless mouse, made sure there was nothing running in the background, run as administrator, everything I could find mention of, I have tried.

The only thing I haven't tried yet is loading the software onto another computer so I can determine if my PC is at fault. It's Windows 10, Intel i5 7400, with 12GB memory, new in 2017.

I'm using a dust system, it is grounded to the structure and with an actual wire to the cravewright. I do not vacuum anything while the machine is on or while the card is installed. I've been very careful with how I handle the memory cards.

If anyone can think of anything else I can try, please let me know.
Thank you

This is the message I get:
Click image for larger version. 

Name:	CV error writing to flash1.jpg 
Views:	9 
Size:	226.0 KB 
ID:	88047

I also get this message on the screen where you load the firmware. Note it says "firmware bad"
Click image for larger version. 

Name:	CV firmare1.jpg 
Views:	9 
Size:	229.2 KB 
ID:	88048