Results 1 to 3 of 3

Thread: File is invalid or corrupted

  1. #1
    Join Date
    Dec 2010
    Location
    Coeur D'Alene Idaho
    Posts
    632

    Default File is invalid or corrupted

    Recently when I go to import a stl file into STL Importer I get the message "File is invalid or corrupted". This is happening to about half of the STL files that I have, many of them I have imported before with no problem. I can open the files in Meshlab with no problem and with making no adjustments to them just save as a stl file then STL Importer works as it should. Does anyone have a clue as to what is happening?

  2. #2
    Join Date
    Apr 2014
    Location
    Texas
    Posts
    2,197

    Default

    I've gotten that fault with broken meshes before but if you have previously opened the stl files then I am unsure what its causing it.

    By broken mesh I mean missing verts (holes) in the visible part of the model.

    Good luck and let us know what you find.

  3. #3
    Join Date
    Dec 2010
    Location
    Coeur D'Alene Idaho
    Posts
    632

    Default

    I have a feeling it may be due to an update that happened automatically. I have a MacBook that updated, not to Catalina but just updated High Sierria. The weird thing is if I download the stl file from where I bought it, it still shows as invalid or corrupt, but Meshlab does not have a problem with it and like I said before do nothing but save it as a stl file and it works fine. I was just hoping someone had an easy fix.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •