Results 1 to 3 of 3

Thread: Meshlab

  1. #1
    Join Date
    Oct 2012
    Location
    Roseburg, Oregon, United States
    Posts
    39

    Default Meshlab

    Is there a tutorial for importing a stl file to meshlab and resizing it and saving it? I tried the tutorial on CW site but it didn't work.

  2. #2
    Join Date
    Apr 2014
    Location
    Texas
    Posts
    2,160

  3. #3
    Join Date
    Oct 2012
    Location
    Roseburg, Oregon, United States
    Posts
    39

    Default

    I found this.
    1) Start up MeshLab and create a "New Empty Project"

    2a)... If you have a HUMONGOUS file, it is easy to reduce the file size without noticeable quality loss. The 385 MB file you described is ridiculously too large. (I would instruct your client to stop sending you files that large - it's not necessary!)

    2b)...Import your STL file into your New Project in MeshLab and click "OK" in the Post-Open Processing window (see screenshot entitled "1-Post-Open Processing"

    2c)...Select Filters/Remeshing,Simplification and Reconstruction/Quadric Edge Collapse Decimation (see screenshot entitled "2-Remesh_Quadric")

    2d)...Take a look at the screenshot entitled "3-Remesh_Settings". Make SURE you check all the boxes exactly as shown in my screenshot. Now, type in a decimal fraction (percentage) of how much you want to diminish the mesh, without going too crazy, or you'll get visible facets on your model. You might try .25 for those HUGE files. NOTE: .25 is NOT the percentage reduction...by typing in .25, you are actually telling MeshLab to reduce by 75%. Not very intuitive, but that's the way it is. EXAMPLES: type .70 for a 30% reduction, type .50 for a 50% reduction, type .90 for a 10% reduction, etc. Also, MAKE SURE you have typed in a value of "1" for the Quality Threshold.

    2e) Click the word "Apply", wait for it to finish, then click the word "Close" to get rid of the window.

    3) Observe your model on-screen to confirm it is still good quality (it will be if you didn't "go crazy" with the remesh reduction)

    4) Now, go to File/Export Mesh As. You will select your file type (STL in this case) and create a new name for your model (so you don't overwrite your original!). Click "Save" and you will see a new window pop-up. There is a setting here you MUST UNCHECK before saving to enable the CW STL Importer to open your new STL (see screenshot entitled "4-Saving_Options"). UNCHECK the box that says "Materialize Color Encoding". Click "OK" to save your new STL. It will now open for you in the CW STL Importer.

    So, we have basically corrected the "troublesome" STL files by doing this. Even though many STL files will open in other programs (like MeshLab here) with the color or texture preserved, some programs won't open them or might even crash on you...the CW STL Importer wants "clean" STL's without color info and a file size smaller than 99MB. Reducing the mesh to a reasonable size and discarding the color/texture info should put you on track. I believe by following these steps when necessary, you will soon learn to enjoy the STL Importer for what it is primarily designed for...converting STL's to PTN files for use with your CW machine.

    I hope this has been helpful. Try it and let us know if it worked for you. If not, post one of your "troublesome" STL's on DropBox and I'll try to fix it for you.

    Additional Info: If you have a file that is already a reasonable size you are comfortable with, then you don't need to do the "remesh/reduction". However you WILL need to go ahead and export the model and remove the "Materialize Color Encoding" in the save options as described above.

    Alan mentioned importing and resaving from Blender (another free program) works well for him. I suspect it is stripping out the material/color info by default. I'm not sure how good a job Blender does for reducing the mesh without a noticeable quality hit - maybe it's fine - but I know for sure that MeshLab does a great job with that.
    [IMG]file:///C:/Users/harpe/AppData/Local/Temp/msohtmlclip1/01/clip_image001.png[/IMG]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •