Results 1 to 7 of 7

Thread: universal carrier base dimensions?

  1. #1

    Default universal carrier base dimensions?

    My version of designer and my computer are both too old to use the UCB24 .mpc. Is there a way to get an exploded dimensioned plan that I could use to cut out the parts with conventional table saw, band saw use?

  2. #2
    Join Date
    Nov 2008
    Vancouver Island


    Why can't you install Designer 1.188 ?? Here is a screen capture. The snap grid is set at 1/4".
    Attached Thumbnails Attached Thumbnails UCB24 Screen Capture.PNG  
    Last edited by bergerud; 07-01-2018 at 08:00 PM. Reason: added picture

  3. #3


    I'll try to install 1.188 again but in the meantime, thanks much for the help with the capture.

    OK 2 hours later or so, I started over with the update to 1.188. I loaded the CD Rom disc that came with my newest carvewright machine, I downloaded the 1.188 version to my desktop anddragged it into my application file (AFTER I first trashed the 1.118 that I had been using). Now I have the page that shows both the readme and the carvewright icon. Typically I would then double click the icon and the designer would open. But, when I do that the icon only shows up on the dock for a split second and drops back off. What can I do now that I have neither version working?

  4. #4
    Join Date
    Jun 2013
    Southeast Idaho


    Have you tried downloading the software from Carvewright?
    Current Basic:

  5. #5


    I used the Current Basic site to try unsuccessfully to update to 1.188. Are you saying that it would possibly work if I used the "older" site and tried to update to the 1.186?

  6. #6
    Join Date
    Feb 2008
    Tucson, Arizona


    Don't use the CD that came with the machine. Most likely it is out dated. Here is the link to the basic 1.88 software. Don't forget to register it so it will be fully functional. If you can, you really should update to version 3.

    EDIT: You should also format and flash the latest firmware to the data card.
    Last edited by SteveNelson46; 07-05-2018 at 09:18 AM.

  7. #7


    Ok, with no CD involved, I went to the link for updates, downloaded the update for the version 1.188, it appeared on my desktop, I dragged it into my application file, I double clicked on it, and it appeared for 1/2 second in the dock and dropped back out. If I try it again it appears for an even less time. So, I can't open it let alone register it. I tried the same by first trashing the 1.188 and trying the 1.186, same result. When I had the older 1.118 version I found that I would have to wait 2-3 seconds between clicking on the desktop icon and then clicking on the icon of the icon/readme box or it would do the same thing, appear in the dock and drop out again.
    I am running with a Mac OS X, version 10.4.11. As I have 2 Carvewright machines I would like to get a version up and running again. Thanks to all for any help with this in advance.
    (The 1.118 would work if I did wait the 2-3 seconds.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts